[Tutoriel] Arduino

Pas de discussions dans cette catégorie, simplement des réponses à des questions précises et/ou récurrentes.

Modérateurs : Carl, Papy.G, fneck

Avatar de l’utilisateur
hlide
Messages : 2219
Inscription : 29 nov. 2017 10:23

Re: [Tutoriel] Arduino

Message par hlide »

Bon j'arrive sur 'SdFatSoftSpi'. J'ai été obligé d'installer à la main le "Bus IO". Il faudrait une liste claire des dépendances à installer.
Patrick
Messages : 1950
Inscription : 16 mai 2009 09:30
Localisation : Clermont-Ferrand

Re: [Tutoriel] Arduino

Message par Patrick »

Quelle est ta version de l'Arduino IDE ?
Patrick
Avatar de l’utilisateur
hlide
Messages : 2219
Inscription : 29 nov. 2017 10:23

Re: [Tutoriel] Arduino

Message par hlide »

1.8.5. je sais pour la 1.8.13 mais je n'ai pas envie de tout faire péter ou de passer par le store de Microsoft, donc je continue sur cette version.
Avatar de l’utilisateur
hlide
Messages : 2219
Inscription : 29 nov. 2017 10:23

Re: [Tutoriel] Arduino

Message par hlide »

Par contre, pourquoi utiliser un soft SPI ?
Patrick
Messages : 1950
Inscription : 16 mai 2009 09:30
Localisation : Clermont-Ferrand

Re: [Tutoriel] Arduino

Message par Patrick »

Le tutoriel a été réalisé avec la version la plus récente de l'IDE, étant donné que je commence au téléchargement de l'IDE.
La gestion des dépendances est certainement une nouvelle fonctionnalité introduite après ta version.
Les librairies utilisées sont listées dans le README du projet GitHub.
Parce que les broches du SPI matériel ne sont pas les mêmes sur le UNO et le Mega. Impossible d'utiliser le SPI matériel sur un bouclier UNO sur le Mega. Il faut passer par un SPI logiciel.
Patrick
Avatar de l’utilisateur
hlide
Messages : 2219
Inscription : 29 nov. 2017 10:23

Re: [Tutoriel] Arduino

Message par hlide »

Ah les versions hardware (50-53) sont occupées... bon je vais devoir modifié le source.
Patrick
Messages : 1950
Inscription : 16 mai 2009 09:30
Localisation : Clermont-Ferrand

Re: [Tutoriel] Arduino

Message par Patrick »

Pardon ? De quoi parles-tu ?
Patrick
Avatar de l’utilisateur
hlide
Messages : 2219
Inscription : 29 nov. 2017 10:23

Re: [Tutoriel] Arduino

Message par hlide »

Les broches pour le SPI hardware sont de 50 à 53. Comme j'imagine qu'elle sont utilisées par le shield pour être associées à quatre des 40 broches du socle de test, ça me paraît très difficile en effet de les utiliser à la fois pour du SPI et du GPIO. J'aurais voulu éviter de toucher au SdFat, mais là je n'ai pas le choix.
Patrick
Messages : 1950
Inscription : 16 mai 2009 09:30
Localisation : Clermont-Ferrand

Re: [Tutoriel] Arduino

Message par Patrick »

Cette possibilité est prévue dans la librairie.
Le problème est qu'une modification dans une librairie est reportée dans tous les projets qui utilisent cette librairie.
Ici, une classe supplémentaire est compilée.
Si un projet ne référence pas cette classe, elle n'est pas incluse dans le binaire, donc l'impact est nul.
Patrick
Avatar de l’utilisateur
hlide
Messages : 2219
Inscription : 29 nov. 2017 10:23

Re: [Tutoriel] Arduino

Message par hlide »

"TFT initialized 0x8585"

J'ai bien compris comment tu as retrouvé à partir de 0x9595 mais là je n'ai pas cette chance, le 0x8585 n'est pas présent dans un case pour dire quel SUPPORT_XXXX je dois décommenter.
Patrick
Messages : 1950
Inscription : 16 mai 2009 09:30
Localisation : Clermont-Ferrand

Re: [Tutoriel] Arduino

Message par Patrick »

Effectivement, cela ne correspond pas à un identifiant supporté.
Tu peux m'envoyer le lien vers l'écran exact que tu as acheté ?
Sinon, tu peux soumettre ton cas à l'auteur de la librairie MCUFRIEND_kbv, David Prentice.
Patrick
Patrick
Messages : 1950
Inscription : 16 mai 2009 09:30
Localisation : Clermont-Ferrand

Re: [Tutoriel] Arduino

Message par Patrick »

Tu peux également essayer d'exécuter le croquis diagnose_TFT_support dans les exemples de la librairie. David te demandera de le faire.
Patrick
Avatar de l’utilisateur
hlide
Messages : 2219
Inscription : 29 nov. 2017 10:23

Re: [Tutoriel] Arduino

Message par hlide »

C'est le lien que tu avais passé dans le topic ICT : https://fr.aliexpress.com/item/32905829057.html.
Je vais regarder l'autre sketch.
Patrick
Messages : 1950
Inscription : 16 mai 2009 09:30
Localisation : Clermont-Ferrand

Re: [Tutoriel] Arduino

Message par Patrick »

Curieux. Il n'y a rien d'indiqué sur le sachet antistatique ? Sur les miens le nom du composant est écrit, HX8347i.
Patrick
Avatar de l’utilisateur
hlide
Messages : 2219
Inscription : 29 nov. 2017 10:23

Re: [Tutoriel] Arduino

Message par hlide »

J'ai posé un fait technique.

le sachet anti-statique mentionne HX8347i.
Répondre