[PC-XT] Dynamit-PC

Pour tout ce qui touche au PC d'IBM et ses nombreux descendants. Attention tout de même, au delà de quelques MHz la discussion devient vite hors sujet.

Modérateurs : Papy.G, fneck, Carl

Avatar du membre
Knabice
Messages : 174
Enregistré le : 19 janv. 2018 23:48
Localisation : Nantes

[PC-XT] Dynamit-PC

Message par Knabice » 03 sept. 2020 16:49

J'ai récupéré cet été 2 vieux PC-XT. (Dynamit-PC et MIKADO écrit dessus...)
Sur l'un il y avait une carte (monochrome je pense) avec une sortie composite.
J'ai pu le démarrer et tout fonctionnait impeccable du premier coup, il a même booter sur le disque MFM.

Sur l'autre la carte graphique ne semblait pas fonctionner. Ce matin j'ai donc échanger les 2 cartes graphique, et effectivement il y a une carte qui n'affiche rien :(

Sur le 2nd PC, il démarre, affiche des trucs (très différents du 1er), mais fini par un écran noir, peut-être au moment de booter sur le disque dur.... puis plus rien.

Bref j'ai remis les cartes en ordre, mais au moment de booter le 1er PC, le POST s'affiche maintenant lentement, par a-coups, et se fige pendant le test mémoire, pas toujours au même moment... ça semble pas être un problème mémoire, il n'y a pas d'erreur. Je suis dégouté :(
Auriez-vous une idée ?
J'ai retiré l'eprom du BIOS, puis réinséré, au passage elle a eu mal à une patte..., mais le problème est toujours le même.
Je me dit que je pourrais essayer une nouvelle eprom ? mais j'ai pas de quoi faire ça bien sûr :)
J'ai vu qu'il existait des BIOS generic genre Super PC/Turbo XT BIOS : https://www.phatcode.net/downloads.php?id=101
Ca marcherait ça ?

Je me doute qu'il va falloir plus de détails des photos et de la méthode peut-être c'est mon problème je sais jamais par où commencer :)

Avatar du membre
fneck
Site Admin
Messages : 13817
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [PC-XT] Dynamit-PC

Message par fneck » 03 sept. 2020 19:18

Je ne pense pas que le problème que tu décris puisse provenir de la ROM. Plutôt la RAM, ou tout ce qui est sur support, ou les connecteurs, le bus ISA... bien que je n'ai pas d'explications pour cela mais le problème arrive après tes manipulations. Cherche déjà de ce coté là.

Avatar du membre
Knabice
Messages : 174
Enregistré le : 19 janv. 2018 23:48
Localisation : Nantes

Re: [PC-XT] Dynamit-PC

Message par Knabice » 03 sept. 2020 19:46

Merci pour cette première réponse.
Je vais essayer demain peut-être de déconnecter toutes les cartes. J'ai déjà essayé d'appuyer un peu sur tous les CI qui sont sur support.
J'ai manipulé que le premier port ISA en fait... Mais j'ai peut-être touché autre chose.

Avatar du membre
jojo
Messages : 513
Enregistré le : 13 mai 2007 13:27
Localisation : Entre la France, la Suisse et l'Italie ... au pays du bien décolleté.

Re: [PC-XT] Dynamit-PC

Message par jojo » 03 sept. 2020 20:30

Est-ce que le boot sur le 2ème PC dont la configuration n'était peut-être pas identique à celle du premier a pu modifier quelque chose ou un paramètre sur la carte ou bien est-ce que le simple fait d'avoir enlevé et remis la carte a pu modifier un paramètre de la config du 1er PC ?
( :oops: Je ne sais pas si je me fais bien comprendre là)

Avatar du membre
Knabice
Messages : 174
Enregistré le : 19 janv. 2018 23:48
Localisation : Nantes

Re: [PC-XT] Dynamit-PC

Message par Knabice » 04 sept. 2020 09:01

Je me demandais aussi, si le fait d'avoir changer les cartes n'avait pas mis le bazar...

J'ai ré-ouvert le 1er PC, et vérifier les cartse ISA. Il y avait une carte (serie/parallèle) mal enfichée.
Je l'ai retirée et le POST se passe maintenant correctement !
Image

En appuyant sur F1 il m'a dit par contre que le disque n'avait pas de système :(
J'ai éteint, triturer la carte contrôleur, les nappes, redémarré et ce coup-ci ça boot sur le disque dur, par contre ça s'est figé assez rapidement après le boot...
Après plusieurs démarrages, j'ai soit disque non système soit ça se fige. Ce doit être la carte contrôleur non ?
Je vais peut-être essayer de retirer et remettre toutes les cartes en nettoyant les connecteurs.

En tout cas c'est déjà beaucoup mieux.
Petite photo de l'intérieur.
Image

FreddyV
Messages : 166
Enregistré le : 10 oct. 2018 09:16

Re: [PC-XT] Dynamit-PC

Message par FreddyV » 05 sept. 2020 19:20

Hello.
Machines sympa.

Achete de la bombe nettoyant contact.

Quand tu debrache un connecteur, un coup de bombe ca ne fais pas de mal.

helmut
Messages : 9
Enregistré le : 25 août 2020 10:50

Re: [PC-XT] Dynamit-PC

Message par helmut » 08 sept. 2020 11:38

Hello !
Perso, ce que j'essaierais de faire déjà c'est virer la carte contrôleur et booter un DOS sur disquette pour voir si tu n'as pas de freeze.
Ta carte contrôleur c'est quoi ? Du seagate ? Est-ce que tu vois son BIOS se lancer après le POST ?
Même si un problème aléatoire peut être lié à un peu tout et n'importe quoi, je pense quand même que le plus probable est que ton disque dur est fatigué. Peut-être que ça peut être intéressant de rentrer dans le BIOS de la carte pour faire un formatage bas niveau et écarter les secteurs qui peinent.
Le mauvais contact des deux connecteurs des nappes c'est assez crédible aussi, je me suis déjà arraché les cheveux sur des boot aléatoires à cause de ça.

Avatar du membre
Knabice
Messages : 174
Enregistré le : 19 janv. 2018 23:48
Localisation : Nantes

Re: [PC-XT] Dynamit-PC

Message par Knabice » 08 sept. 2020 17:03

Merci j'essaierais.
Le problème c'est que j'ai pas de disquette 5"1/4 DOS bootable
Faut que j'essaie de créer une disquette à partir du disque dur ou brancher un gotek.
Déjà j'ai pas eu le temps de tout débrancher et nettoyer...

Avatar du membre
Knabice
Messages : 174
Enregistré le : 19 janv. 2018 23:48
Localisation : Nantes

Re: [PC-XT] Dynamit-PC

Message par Knabice » 09 sept. 2020 16:03

Aujourd'hui j'ai pris un peu de temps pour démonter toutes les cartes, nettoyer les connecteurs.
Juste le disque dur que j'ai pas réussi à sortir, il y a 2 vis d'un côté mais ensuite on sent que c'est fixer de l'autre côté et aucun accès visible...
Au redémarrage ça boot correctement sur le disque dur, cool.
Je fourre une disquette dans le lecteur, et je lance un format a: /s
A ma grande surprise ça fonctionne jusqu'au bout sans erreur.
Je passe ensuite un peu de temps à recopier des fichiers DOS utiles vers la disquette sans soucis. Juste un fichier qui fait une erreur générale d'accès.
Le disque dur est à vérifier à mon avis.
La disquette pleine, je reboot, et il boot gentiment sur la disquette :) J'ai maintenant une disquette DOS 4.01 bootable :mrgreen:
Je n'ai pas eu de freeze depuis, il a fonctionné 30 minutes je dirais sans broncher.
Que me conseilleriez vous de faire maintenant ? Vérifier le disque ?
J'aimerais bien le réinstaller, ça provient d'une école, mais je pense qu'il vaudrait mieux y brancher un gotek pour être plus tranquille.
En attendant quelques photos.

Le disque dur :
Image

La carte mère :
Image

La carte graphique (MDA ???) :
Image

La carte controleur HDD :
Image
Image

La carte controleur FDD :
Image

Le PC qui fonctionne :)
Image

Avatar du membre
fneck
Site Admin
Messages : 13817
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [PC-XT] Dynamit-PC

Message par fneck » 09 sept. 2020 19:32

Ce n'était donc, a priori, qu'un problème de mauvais contacts oxydés, ce qui finalement est assez courant sur une machine de cet age. Par contre as-tu aussi nettoyé les têtes du lecteur de disquette? Ce n'est pas forcément inutile car elle sont peut-être dans le même état que le reste et d'ici quelques temps la disquette que tu as écrite sera illisible... Attention, c'est assez fragile, mais l'ordinateur ouvert c'est en général plus simple car on peut voir les têtes.

Avatar du membre
Knabice
Messages : 174
Enregistré le : 19 janv. 2018 23:48
Localisation : Nantes

Re: [PC-XT] Dynamit-PC

Message par Knabice » 09 sept. 2020 21:57

J'ai pas fait les têtes du lecteur, mais effectivement ça vaut le coup. Surtout que capot ouvert on peut directement accéder aux têtes sans démonter quoique ce soit tu as raison.

helmut
Messages : 9
Enregistré le : 25 août 2020 10:50

Re: [PC-XT] Dynamit-PC

Message par helmut » 10 sept. 2020 17:49

A mon avis ta carte video c'est du CGA.
D'une part parce que tu as une sortie composite, qu'on retrouve surtout sur ces cartes. Et puis de toute façon le MDA c'est du 18Khz en synchro horizontale donc ça ne fonctionnerait pas sur une télé.
Et autre indice, si tu regardes ton connecteur DE9, les broches 3 à 5 correspondant au rouge/vert/bleu sont connectées et vont vers la 74LS244N (U15) qui est un driver donc ça doit sortir quelque chose.
Et dernier indice : les deux puces sur support sont des RAM, j'ai regardé la doc, ça fait 16Ko en tout ce qui est la RAM standard sur une carte CGA.
Ce que je trouve curieux par contre c'est que la puce U1 en haut à gauche soit sur support, peut-être une réparation d'époque ?

Avatar du membre
Knabice
Messages : 174
Enregistré le : 19 janv. 2018 23:48
Localisation : Nantes

Re: [PC-XT] Dynamit-PC

Message par Knabice » 11 sept. 2020 10:52

T'as vu tout ça sur la photo !?
Bravo.

Effectivement le U1 sur support c'est bizzare

Avec la seconde carte graphique, j'entends le moniteur "siffler" comme si quelque chose allait s'afficher mais l'écran reste noir.
C'est peut-être pas grand chose, faudrais que je regarde en détail.

Image

helmut
Messages : 9
Enregistré le : 25 août 2020 10:50

Re: [PC-XT] Dynamit-PC

Message par helmut » 11 sept. 2020 13:36

Cette carte ressemble à ça :
https://particolarmente-urgentissimo.bl ... g-808.html

De toute façon, du CGA aussi.
Tu l'as branchée sur quel genre de moniteur ??

Avatar du membre
Knabice
Messages : 174
Enregistré le : 19 janv. 2018 23:48
Localisation : Nantes

Re: [PC-XT] Dynamit-PC

Message par Knabice » 11 sept. 2020 15:42

Ha oui bien vu.
J'ai 2 moniteurs ambre avec les 2 PC.
Sur la 1ere carte ça affiche bien mais l'image défile verticalement (sur les 2 moniteurs), j'ai ouvert les moniteurs, et tourné tous les potentiomètres rien à faire :(
Sur la 2nde carte ça n'affiche rien ni sur la sortie DE9 ni en composite, mais sur l'écran CRT on entend un léger sifflement quand ça se met en route, y'a qqchose qui sort.
Modifié en dernier par Knabice le 11 sept. 2020 17:32, modifié 1 fois.

Répondre